侧边栏壁纸
博主头像
梦荟楼的后花园博主等级

干啥啥不行干饭第一名

  • 累计撰写 51 篇文章
  • 累计创建 126 个标签
  • 累计收到 0 条评论

目 录CONTENT

文章目录

华为交换机解决设备观察端口不足的问题

梦荟楼
2024-01-16 / 0 评论 / 5 点赞 / 118 阅读 / 5740 字 / 正在检测是否收录...
温馨提示:
本文最后更新于 2024-01-16,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

如何解决设备观察端口不足的问题

设备上的观察端口规格和1:N规格是有限的,如果当前需要连接的监控设备有很多,需要的观察端口数量超过了规格上限,一般可以通过以下两种方式解决。

配置远程镜像,通过远程观察端口进行内部环回广播

  • 此方案中如果配置多个内部环回口,则需要确保这些环回口加入的VLAN ID不能相同,否则会导致环路。
  • 仅把连接监控设备的端口加入内部环回VLAN,如果有其他端口以Trunk方式加入内部环回VLAN,要及时退出内部环回VLAN,防止VLAN内流量广播。

图1 通过内部环回方式连接多监控设备组网图

fig_dc_cfg_mirror_100706_xs.png

图1所示,网络管理员需要将镜像端口的报文镜像到4台监控设备,而SwitchB可配置观察端口数量少于4。通过远程观察端口内部环回广播的实现过程如下:

配置远程端口镜像
<SwitchB> system-view
[SwitchB] observe-port 1 interface gigabitethernet0/0/1 vlan 20   //配置远程观察端口,VLAN20为用于内部环回广播的VLAN
[SwitchB] interface gigabitethernet0/0/6
[SwitchB-GigabitEthernet0/0/6] port-mirroring to observe-port 1 both   //将镜像端口出入方向报文都镜像到内部环回用的远程观察端口
[SwitchB-GigabitEthernet0/0/6] quit
配置内部环回功能
[SwitchB] vlan batch 20   //用于内部环回转发,不能在VLAN20配其他业务。
[SwitchB] interface gigabitethernet0/0/1
[SwitchB-GigabitEthernet0/0/1] mac-address learning disable   //关闭端口MAC动态学习功能,防止内部环回端口学习到其他的MAC地址,将非镜像报文在内部环回转发,同时也可以节省MAC表项资源
[SwitchB-GigabitEthernet0/0/1] stp disable   //关闭STP功能,避免内部环回端口因收到设备自己发送的报文,设置成Discarding状态,将端口阻塞
[SwitchB-GigabitEthernet0/0/1] port link-type access
[SwitchB-GigabitEthernet0/0/1] port default vlan 20   //将端口加入内部环回广播用的VLAN
[SwitchB-GigabitEthernet0/0/1] loopback internal   //将远程观察端口配置为内部环回端口
[SwitchB-GigabitEthernet0/0/1] quit
[SwitchB] interface gigabitethernet0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type access
[SwitchB-GigabitEthernet0/0/2] port default vlan 20   //将端口加入内部环回广播用的VLAN
[SwitchB-GigabitEthernet0/0/2] quit
[SwitchB] interface gigabitethernet0/0/3
[SwitchB-GigabitEthernet0/0/3] port link-type access
[SwitchB-GigabitEthernet0/0/3] port default vlan 20   //将端口加入内部环回广播用的VLAN
[SwitchB-GigabitEthernet0/0/3] quit
[SwitchB] interface gigabitethernet0/0/4
[SwitchB-GigabitEthernet0/0/4] port link-type access
[SwitchB-GigabitEthernet0/0/4] port default vlan 20   //将端口加入内部环回广播用的VLAN
[SwitchB-GigabitEthernet0/0/4] quit
[SwitchB] interface gigabitethernet0/0/5
[SwitchB-GigabitEthernet0/0/5] port link-type access
[SwitchB-GigabitEthernet0/0/5] port default vlan 20   //将端口加入内部环回广播用的VLAN
[SwitchB-GigabitEthernet0/0/5] quit

配置远程镜像,通过中间二层设备进行VLAN广播

图2 通过中间二层设备连接多监控设备组网图

fig_dc_cfg_mirror_100707_xs.png

图2所示,网络管理员需要将镜像端口的报文镜像到3台监控设备,而SwitchB可配置观察端口数量少于3。通过SwitchC进行VLAN广播的实现过程如下:

在SwitchB配置远程端口镜像
<SwitchB> system-view
[SwitchB] observe-port 1 interface gigabitethernet0/0/1 vlan 20   //配置远程观察端口,VLAN20为用于转发镜像报文的普通VLAN
[SwitchB] interface gigabitethernet0/0/2
[SwitchB-GigabitEthernet0/0/2] port-mirroring to observe-port 1 both   //将镜像端口出入方向报文都镜像到远程观察端口
[SwitchB-GigabitEthernet0/0/2] quit
在SwitchC配置端口加入VLAN
[SwitchC] interface gigabitethernet0/0/1
[SwitchC-GigabitEthernet0/0/1] port link-type trunk
[SwitchC-GigabitEthernet0/0/1] port trunk allow-pass vlan 20   //将端口加入用于转发镜像报文的VLAN20
[SwitchC-GigabitEthernet0/0/1] quit
[SwitchC] interface gigabitethernet0/0/2
[SwitchC-GigabitEthernet0/0/2] port link-type access
[SwitchC-GigabitEthernet0/0/2] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
[SwitchC-GigabitEthernet0/0/2] quit
[SwitchC] interface gigabitethernet0/0/3
[SwitchC-GigabitEthernet0/0/3] port link-type access
[SwitchC-GigabitEthernet0/0/3] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
[SwitchC-GigabitEthernet0/0/3] quit
[SwitchC] interface gigabitethernet0/0/4
[SwitchC-GigabitEthernet0/0/4] port link-type access
[SwitchC-GigabitEthernet0/0/4] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
[SwitchC-GigabitEthernet0/0/4] quit
5

评论区